Announcements

I need to redirect user to a url, which is 5000+ characters long.
To do that I set:

set %response.Redirect = url

However, in the browser I receive this header:

LOCATION: <First 3972 characters of the 'url' variable>

In WriteHTTPHeader method of %CSP.Response, where the LOCATION header is
written:

Write "Location: ", <Redirect>,!

After I added a buffer flush, after the above-mentioned line:

0   0 2
0

answers

193

views

0

rating

We have started playing around with Atelier, primarily to enable us to commit our existing Ensemble code within source control (GIT). 

It seems Atelier works well with classes and routines however is unable to directly export lookup tables and HL7 schemas. Can someone confirm/validate this is the case? if so, when will this functionality be made available as it's absence is a deal breaker for us?

Last comment 15 July 2018
0   0 2
0

answers

219

views

0

rating

Hi, 

We have a PAS that accepts HL7v2 QBP^Q21 requests, and returns patient details in an RSP^K21.

We have a clinical system that wants to sent an http GET request of the form http://server/getpatientbyid?pid=M1234567

So I think I need to convert the query url into a QBP^Q21 (HL7) message, then take the response in HL7v2, convert to SDA, convert to FHIR, and put that in the response to the  original GET.

Does anyone have any experience doing this? is there an approach you would recomend?

Last comment 19 April 2018
0   0 3
0

answers

591

views

0

rating

When I try to compile through Atelier (Compile Project), I noticed that in compilation with error it returns this message 'Failed to read /api/atelier/v1/ ...':

No additional Atelier files to synchronize.
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck
Compile failed: Failed to read /api/atelier/v1/ERP/action/compile?flags=ck

Last comment 24 July 2018
+ 1   0 4
0

answers

271

views

+ 1

rating

Hi,

I have a question related with EnsLib.SQL.OutboundAdapter adapter.

Is there a way to open an oracle transaction and do either commit or rollback depending on the query result?

Is posible to keep open an oracle transaction to execute a lot of queries on different methods on the same business operation and do a commit when the business process finished?

Thanks and Best Regards

Last comment 24 July 2018
0   0 2
0

answers

194

views

0

rating

Often, the first time I start up Eclipse (Atelier plug-in), all of my local classes indicate "warning" as if they are out-of-sync. When I  try to synchronize, I get the following error:

Synchronization failed: [server is broken] java.lang.ClassNotFoundException: Provider org.glassfish.jersey.internal.RuntimeDelegateImpl could not be instantiated: java.lang.IllegalStateException: No generator was provided and there is no default generator registered

Last comment 5 July 2018
0   0 5
0

answers

274

views

0

rating

I have previously setup an Atelier project and it was running. I recently received the 1.3 release. Now, I am unable to click on the previously established connection to my Cache server (as seen in the Serve Explorer. I see the connection and the little arrow (implying that there is a hierarchy of items underneath). But, clicking that arrow opens nothing. Ultimately, I was trying to access files on the server so that I could add some new ones to my existing Atelier Project.

Last comment 2 October 2018
0   0 3
0

answers

132

views

0

rating

I tried to access Caché using ADO.NET. This works fine but when I want to use Entity Framework, I can't access the Caché Data Source.

I'm using Visual Studio 2017, and followed the procedure described in Caché documentation.

(This document has been written  regarding VS2013)

Did some meet the same problem ?

Thanks in advance.

 

 

Last comment 21 March 2018
0   0 4
0

answers

363

views

0

rating

Without installing Kerberos has anyone Authenticated a SQL JDBC connection? Currently we are using local SQL Accounts to sign onto External SQL Databases, but we are being told that we need to switch to Service accounts that live on a Active Directory Domain. 

I wrote with a little help a ZAUTHENICATE to do the Authentication for Ensemble, can I use something like that to connect to an External SQL Database using a Service Account on a Active Directory Domain?

Thanks

Scott

Last comment 7 June 2018
0   0 3
0

answers

225

views

0

rating

Sounds odd - but I encountered it - twice now. Cache was restarted. in that period the primary journal directory was full and it was writing to the secondary journal directory. So upon start-up, it was quite obvious that it was not going to write to the primary. Cache reported this but was able to continue with the start-up but writing to the secondary. All of a sudden it doesn't recognize the 'primary' config any more and started saying 'Alternate and primary journal directories are the same'.

Last comment 29 March 2018
0   0 3
0

answers

318

views

0

rating

Hello  ,

         Ensemble Business Process seems like red color but it still processing message successfully. I have checked log, events, queue everything is clear. there is no log info or error in the history.  If BP is in red color in the sense might have some issues, but is still processing messages successfully.

 Can you guys please advice on this.

Last comment 23 July 2018
0   0 2
0

answers

127

views

0

rating

Any insights, news, alternatives or experience about sequence pattern querying like with Oracle's MATCH_RECOGNIZE, more declarative, less simple direct COS way? Both obvious solutions (shadowing data to oracle cloud or implementing MATCH_RECOGNIZE compiler in COS from scratch) seem big overkill. Do Intersystems have plans to adopt this "2007 ANSI standard proposal" and "SQL:2016 standard"

Last comment 4 May 2018
0   0 2
0

answers

218

views

0

rating

I have a CSP REST web application where I'm using delegated authentication via basic authentication in the REST calls. When I do a call to the web app with correct user credentials, I get a  CSPSESSIONID cookie back representing the CSP session, which has started for the user I'm logged in with.

And when I want to log out/end the CSP session with the "CacheLogout=end" query parameter, I get a 401 Unauthorized code back. But the csp session itself does get terminated, which means the logout call was successful.

Last comment 10 July 2018
0   0 3
0

answers

251

views

0

rating

Hi,

My [Ensemble] > [Queues] page shows message queues for Operations that were deleted months ago.

When I deleted the Operations I thought Ens.Util.Tasks.Purge would cause the (empty) queues to disappear from the Queues page.

Is there a way to remove queues that no longer refer to an operation?

Kind regards,

Stephen

Last comment 5 December 2018
0   0 4
0

answers

174

views

0

rating

Hello All,

Hoping someone can help with this odd error.

A vbscript file is being used to perform an update to cache.

The file has worked without an issue for well over a year.

Recently, the update has begun to throw an error.

(class references modified to remove client data)

UPDATE CACHE.UCI.Reg.Pat (Column1) VALUES ('USERNAME') WHERE ID = '2190284'

C:\Web\Config\SchedTasks\script1.VBS(73, 6)

Microsoft OLE DB Provider for ODBC Drivers: [Cache ODBC][State : S1000][Native Code 105]

[c:\Windows\SysWOW64\cscript.exe]

Last comment 14 December 2018
0   0 2
0

answers

128

views

0

rating

Hi,

I have a problem with CSP Application Authentication, when the user input you correct password, however the message "Invalid password" returns.

This error returns just Cache password user type, for user delegated don't.

this error is momentary also, if you wait a moment, it stops.

Last comment 20 July 2018
0   0 2
0

answers

243

views

0

rating